Anycast
Whether for your own or your clients’ domain names, DNS stability and reliability is crucial for success in the domain (DNS) hosting area. Many of you take advantage of our long-time experience in DNS management and monitoring and use our powerful KeyDNS services free of charge.
Key points to be aware of when using our DNS:
1. Hostnames for NS, MX and SRV records must not contain underscores
Some records within the DNS are not allowed to have underscores in them. We enforce stricter compliance to the DNS RFCs with the following rules:
- NS records with underscores are not be supported (RFC952 - Assumptions 1.).
- MX records pointing to domains which contain an underscore are not supported (RFC1035 3.3.9).
- SRV records cannot contain underscores anywhere in the TARGET portion of the record (RFC2782 - Target).
Domains that do not meet these criteria may stop working.
2. TTLs will be increased to 60 seconds if less than 60 seconds
To avoid excessive query volumes on our DNS infrastructure, the Time To Live (TTL) of resource records being less than 60 seconds will not be supported.
Additionally, the Start Of Authority (SOA) TTL will require a minimum value of 60 seconds for retry, refresh, expire and negTT.
Please ensure that these are configured correctly in your zone files and be aware they will be automatically adjusted in existing zone files.
3. A single Domain-Record Type pair must have less than 1,000 records
As this is a free service, we have a restriction that Domain-Record Type pair can only have a maximum of 1,000 records within the zone. This is unlikely to be an issue on any of the zones you have, but it is a restriction we wanted to make you aware of.
4. TXT records will have a stricter syntax check on quotes used
If the following conditions are not met, then it is not set up properly and it will be hidden.
All content should be enclosed within double quotes.
There cannot be an odd count of double quotes.
Current IP Addresses
Section titled “Current IP Addresses”Our nameservers use the following IP addresses.
| ns1.rrpproxy.net | 193.227.117.226 | 2a04:2b00:14cc::226 | Cloud 1 (mandatory) |
|---|---|
| ns2.rrpproxy.net | 194.50.187.226 | 2a04:2b00:14dd::226 | Cloud 2 (mandatory) |
| ns3.rrpproxy.net | 194.0.182.226 | 2a04:2b00:14ee::226 | Cloud 1 + Cloud 2 (optional) |
Please kindly note, if 2 of our IP addresses are used for white labelling the DNS nameservers, do ensure always to use IPs from Cloud 1 (193.227.117.226 / 2a04:2b00:14cc::226) and Cloud 2 (194.50.187.226 / 2a04:2b00:14dd::226).
Whitelabel Nameservers
Section titled “Whitelabel Nameservers”IP Addresses for the whitelabel nameserver set.
| ns1.dnsres.net | 193.227.117.225 | 2a04:2b00:14cc::225 |
|---|---|
| ns2.dnsres.net | 194.50.187.225 | 2a04:2b00:14dd::225 |
| ns3.dnsres.net | 194.0.182.225 | 2a04:2b00:14ee::225 |